Issues with notification emails
Incident Report for Typeform
Resolved
We have fixed the issue affecting our email notification service and you'll start to receive those emails now

We’re sorry if it affected you. We’re poring over things to make sure it doesn’t happen again.
Posted 10 months ago. Dec 14, 2017 - 10:57 CET
Investigating
There’s some unscheduled downtime affecting our email service. Our best detectives are busy sleuthing to solve the case and we'll update you as soon as we know more
Posted 10 months ago. Dec 14, 2017 - 10:50 CET