Typeform Panels Temporarily Unresponsive
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 09, 2017 - 09:40 CET
Investigating
We are aware of an issue: the panels are temporarily unresponsive. Our team are investigating at the moment. We will provide update shortly.
Posted 3 months ago. Feb 09, 2017 - 09:22 CET