Typeform.com
Incident Report for Typeform
Resolved
Our public site https://www.typeform.com/ is now accessible. We will be conducting an investigation to ensure this type of issue does not occur again.
Posted 7 months ago. May 24, 2017 - 16:44 CEST
Investigating
Our public site www.typeform.com is currently inaccessible. Our team are working on resolving this as soon as possible.
Posted 7 months ago. May 24, 2017 - 15:51 CEST