Result Processing
Incident Report for Typeform
Resolved
All results are now being displayed as expected and downloading of results is functionality is restored.

We're sorry for the disruption and we will continue monitoring to ensure there isn't a reoccurrence.
Posted 12 months ago. Oct 30, 2017 - 17:29 CET
Investigating
We're currently experiencing an issue with submissions displaying in the results table and exporting results.
We appreciate your patience while we work to resolve the issue and will provide an update as soon as possible.
Posted 12 months ago. Oct 30, 2017 - 17:07 CET