Admin and Forms outage
Incident Report for Typeform
Resolved
Forms and admin are now fully operational. We apologise for any disruption this caused!
Posted 5 months ago. Jan 18, 2017 - 10:20 CET
Investigating
We are currently investigating an issue affecting forms and the admin area. We will post another update shortly with further information
Posted 5 months ago. Jan 18, 2017 - 10:16 CET