Help Center's 'Submit a Ticket" not working
Incident Report for Typeform
Resolved
Our Help Center's “Submit a Ticket” functionality is back to full operation and you can now resume submitting a ticket like normal.
Our apologies for any inconveniences caused.

https://www.typeform.com/help/submit-ticket/
Posted about 1 year ago. Sep 27, 2016 - 21:22 CEST
Investigating
We are experiencing an issue where our Help Center's “Submit a Ticket” functionality is not working.

We are currently investigating the cause, but rest assured this does not affect the Typeform platform, your typeforms, or their data. You can still log in at http://login.typeform.com and your typeforms will continue to work as before.

We hope to bring the Support Form back online very soon, but in the meantime, if you need to submit a Support ticket, please use this link: https://successteam.typeform.com/to/HAPWTp
Posted about 1 year ago. Sep 27, 2016 - 19:57 CEST