Typeform Admin is degraded
Incident Report for Typeform
Resolved
This incident has been resolved. Thanks for your patience!
Posted 7 days ago. Oct 09, 2018 - 18:40 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 7 days ago. Oct 09, 2018 - 17:33 CEST
Investigating
Looks like our Admin is having some trouble again. We're investigating.
Posted 7 days ago. Oct 09, 2018 - 17:15 CEST
This incident affected: Back-End.