Degraded forms performance
Incident Report for Typeform
Resolved
We have resolved the issue with forms performance, this was due to a temporary high load on our servers which we have now mitigated.
Posted Mar 15, 2016 - 18:31 CET
Investigating
We are noticing degraded performance on forms at the moment which we are investigating.
Posted Mar 15, 2016 - 18:03 CET