Typeform Platform - Displaying Results
Incident Report for Typeform
Resolved
We have resolved the issue of displaying results in the results table, however, some users may notice a delay in their results appearing. You can contact our Support team (support@typeform.com) if you have any further concerns.

Thanks for bearing with us while we worked on fixing this.
Posted about 1 year ago. Jun 27, 2017 - 19:11 CEST
Investigating
We're currently experiencing an issue displaying results in the results table but this is not impacting forms or saving results.

We appreciate your patience while we work to resolve the issue and will provide an update as soon as possible.
Posted about 1 year ago. Jun 27, 2017 - 14:25 CEST