Typeform Admin is down
Incident Report for Typeform
Resolved
This incident has been resolved. Thanks for your patience!
Posted 7 days ago. Oct 09, 2018 - 17:03 CEST
Investigating
There’s some unscheduled downtime affecting our admin. Our best detectives are busy sleuthing to solve the case.
Posted 7 days ago. Oct 09, 2018 - 16:54 CEST
This incident affected: Back-End.