Admin and Forms outage
Incident Report for Typeform
Resolved
The issue has now been resolved, access to admin and forms has been restored. Apologies for any inconvenience caused.
Posted 10 months ago. Feb 20, 2017 - 15:50 CET
Investigating
We are investigating an issue that is preventing admin and forms from loading. Further updates will be provided as soon as possible.
Posted 10 months ago. Feb 20, 2017 - 15:47 CET