Unscheduled downtime
Incident Report for Typeform
Resolved
The issue affecting typeform.com, the Help Center and our blog has now been resolved. We are very sorry for the inconvenience.
Posted Sep 09, 2016 - 11:23 CEST
Update
The issue affecting our Help Center and Blog has now been resolved. Typeform.com is still experiencing an unscheduled downtime and we are working on a fix as quickly as possible.
Posted Sep 09, 2016 - 10:53 CEST
Investigating
We are currently experiencing an unscheduled downtime affecting our public website, help center and blog. As soon as we have further updates we will let you know.
Posted Sep 09, 2016 - 10:31 CEST