MAINTENANCE
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 20, 2017 - 14:29 CET
Monitoring
Scheduled maintenance is currently in progress, we will provide updates as necessary. Our apologies for any inconvenience it may cause.
Posted 5 months ago. Jan 20, 2017 - 14:14 CET