Delay in the results queue
Incident Report for Typeform
Resolved
The issue has been fixed. Receiving results is back to normal speed.
Posted Feb 27, 2015 - 12:20 CET
Identified
We have identified an issue with our results queue this morning, causing delays in receiving results.
Posted Feb 27, 2015 - 12:11 CET