Some users experiencing 404s
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted Apr 29, 2015 - 16:07 CEST
Investigating
We are getting reports of some users seeing 404s when using the platform, but refreshing the page will fixes it. We are currently investigating.
Posted Apr 29, 2015 - 15:26 CEST