Platform intermittently down
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted Feb 14, 2018 - 16:02 CET
Update
Multiple expensive calls to the database are causing disruptions to our operational status. We're investigating.
Posted Feb 14, 2018 - 16:01 CET
Investigating
We are currently investigating this issue.
Posted Feb 14, 2018 - 15:59 CET