Results submission delay
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted Jun 14, 2016 - 20:46 CEST
Monitoring
This morning from 11:00-11:50 CET we experienced an issue that prevented results from reaching the Results table of some typeforms. We're back to normal and currently investigating the cause and reviewing responses submitted during that time. Our apologies for the inconveniences caused.
Posted Jun 14, 2016 - 13:12 CEST