Unscheduled Downtime
Incident Report for Typeform
Resolved
This incident has been resolved.
Posted Jul 10, 2014 - 19:05 CEST
Investigating
We're currently experiencing unscheduled downtime of the platform. We're working to resolve this as quickly as possible m.
Posted Jul 10, 2014 - 19:02 CEST